Periodiska fel

Tekniska beskrivningar rörande monteringar, drivning, elektronik etc.
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-04 11:36:57

Ja nu ser jag, det är bilden kl 17:54 som är med guidning och där är pulserna med och urskiljbara. Ser ut som om den är lite okänslig och genererar korrigeringspulserna för sällan så felet hinner bli onödigt stort. Lite av den tendensen kan jag se när jag går från 1 sekund till 2 sekunder.

Du har inte fått fatt i kalibreringsbilden? Den kan säga mycket om bakomliggande fel.

Den blå kurvan på RA utan guidning du lagt upp senare ser väl väldigt bra ut tycker jag, den bör inte vara något problem att guida på, så länge det inte är några tvära kast och det har du ju inte. Att blanda in PEC på det känns som meningslöst, fyller ju ingen funktion på en sådan kurva och den bygger ju också på att motorhastigheten puls regleras precis som vid guidning antar jag.

Du har väl också stegmotorer i din montering precis som på en EQ6 och inte servostyrda DC motorer, eller?

Ser inte i texten, men du använder väl inte ST4 pulsingången? Det fungerar sämre än att via mjukvaran köra mjukvarukommandon för styrningen.

Nu skadar väl det inte att ta isär monteringen och göra rent och på med nytt fett samt justera kuggingrepp. Men det är ju ingen 100kkr montering så man kan kanske inte förvänta sig så mycket. Lägg gärna upp lite bilder på hur mekaniken ser ut, kan vara intressant för många att se.

Jag vill ju gärna i framtiden komma ned mot 0.5" tot rms avvikelse, men har inga planer att med EQ6:an att nå dit, utan satsar på något annat i framtiden när det dyker upp. Har för övrigt inga sådana behov för tillfället där jag bor.

Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-04 15:48:34

Bilderna på de två oguidade sessionerna ovan, uppvisar svängningar i monteringens RA-led på 30-40 arc-sec. Svängningarna är inte regelbundna och därmed mycket svåra att bli av med.

Men,
sådana svängningar innebär egentligen inga problem, så länge de bara är tillräckligt långsamma. Och de yviga rörelserna i RA under guidning, med RMS på 1.5-2.0 kan mycket väl bero på annat...
Är det vad ni säger?


Är det den här bilden du menar Lars?

Screenshot.jpg
Screenshot.jpg (66.21 KiB) Visad 1890 gånger



Motorerna på CGEM är ”DC Servo motors with encoders, both axes” enligt manualen.

Tror inte jag använder ST4 utan kör ASCOM på datorn, med USB-kablar mellan dator och guidekamera samt mellan dator och handkontroll på monteringen. Det är väl riktigt?

/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-04 21:52:00

Jo långsamma svängningar utan ryck brukar inte vara svårt att guida bort om avvikelsen inte är för stor. Glappet skall ju vara lågt också, mest problem i dec axeln.

Allt måste ju också vara ordentligt åtdraget.

DC motorer har jag ingen erfarenhet av vid guidning, kanske ställer något annat krav, men borde väl inte göra det, möjligen om det är begräsningar i vinkel givarens upplösning.

Kurvan säger med sina jämt fördelade punkter att glappet är under kontroll. Har man mycket glapp eller dödgång i DEC så hamnar mätpunkterna i en hög i ena kanten. Ser också att guide kameran sitter snett med 8 grader. Tror man skall hålla sig under 10 grader för att inte få stora problem.



Update:
Tog en titt igen på kalibrerings rapporten. Såg något som jag inte tänkt på tidigare eller lagt märke till. Det står att guid hastigheten är x0.97, vad är RA hastigheten satt till, stellar, sun, moon eller ?

Ser också att förväntad hastighet inte stämmer med riktig hastighet, men du hade skrivit att polinställningen var bra. Kanske du inte har angivit rätt fokallängd eller pixelstorlek. Kan kanske bero på att din guide kamera sitter lite snett också. Borde väl dock kalibreras bort.

På min EQ6 tillsammans med EQMOD får man fintrimma RA hastigheten pga bug i styrkortet eller va det nu beror på. Fast det är nog speciellt för EQ serien och inget du borde ha problem med.

Jo ett test till du kan göra är att inte köra motorerna alls och lång exponera. Då skall stjärnorna ge raka fina streck, är något löst och glappar om det blåser borde det synas direkt som krokiga streck med kanske i det här fallet 5" till 10" spridning.

Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-05 12:38:51

Tack Lars.

Enligt PHD2-manualen verkar inte kamerans vridning spela någon roll. De har i manualen ett exempel där det råkar vara 13 grader, men jag skall justera den ändå. Om inte annat så är det snyggare med DEC avsatt på Y-axeln och RA på X-axeln.

Tracking rate är ”Sidereal”

"Autoguide Rate" hämtar PHD2 från monteringen, där jag satt den till 0.97x. Egentligen rekommenderas 1.0x, vilket ”tillåter” PHD2 använda en justeringshastighet på +/- 1.0 x Tracking Rate.
0.97 har jag bara satt för att minska risken att råka ut för backlash i RA. Med min nuvarande inställning tillåts PHD2 guida i spannet 0.03 - 1.97 x Tracking Rate om och när det behövs.

Fokallängden är väl kanske större?
8” f/10 = 2032 mm. Med fokalreducerare f/6,3 = 1280 mm. Tillkommer gör eventuellt de 105 millimetrarna till sensorn och de kanske skall räknas med i fokallängden, eller?


Det sista var ett intressant test jag skall pröva när jag skruvat ihop monteringen igen. Om jag därtill "slewar" själv, i exempelvis dubbel hastighet, bör jag ju se återkommande ryck i strecken efter eventuell PE...

/a
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-05 13:23:05

Hej Anders,
Det var länge sedan då jag var inne i detaljerna på PHD och Guide speed har jag inte tänkt på förut. Blir ju så när allt fungerar och man bara fortsätter och använder det. Men det måste vara som du säger att Guide Speed är en hastighet man sätter. Fast brukar man inte använda -x0 och +x1 för RA och +/- x1 för DEC eller däromkring ?

Däremot Expected rate för RA och DEC tror jag har något att göra med fokallängd eller pixel storlek. Fokallängden kan vara lite svår att beräkna exakt. Avståndet sensor - reducer påverkar men den skall ju sitta på ett exakt avstånd för ditt teleskop, kanske avviker från standard måttet. Analysera dina bilder istället, om du vet exakta pixel storleken för huvudkameran till ex och fotar två stjärnor där du har exakta avståndet i bågsekunder för får du pixel skalan och då kan du räkna ut ganska exakt vilken fokallängd du har. Försök att lägga stjärnorna längs en rad eller kolumn så blir det enklare.

Vinkeln på kameran avser guide kameran och den fungerar bäst om den är orienterad efter de axlar den guidar efter. Huvud kameran kan sitta i vilken vinkel som helst, men jag brukar orientera långsidan efter RA axeln. Om jag återvänder till objektet i framtiden stämmer då bilderna överens och jag kan stacka ihop historiska och nya bilder med bra precision.

Blir intressant att se vad det nya testet ger för information.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-05 14:29:09

Det var intressant! Min Fuji XT-1 har pixlar på 4,76 mikrometer, mitt teleskop med fokalreducerare har 2032*0,63 = 1280 mm

Jag har en formel för pixelskala: ”Pixel Size/Telescope Focal Length x 206.265” vilket i mitt fall blir 4,76/1280x206,265 = 0,77 arc.sec/px.
Jag har en ganska nytagen bild på Dubbel-Dubbel 1 & 2 vid Vega. Det är ungefär 210 arc.sec mellan dem och avståndet på bilden är 270-275 px, 210/272=0,77 arc.sec/px!

Således torde väl fokallängden verkligen vara 1280mm och avståndet mellan reducerare och sensor i det närmaste perfekt? Kan det verkligen vara så enkelt?


Angående guide speed +/- 1,0 i PHD2 kan man väl säga att man ger programmet fria tyglar att jaga guidestjärnan såsom programmet anser vara bäst...


/a
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-08 00:56:44

Hej Anders,
Jo det verkar vara rätt formel. Då stämmer det bra också med din setup så ett problem mindre.

Funderar lite över guide speed, blev lite osäker här. Men det skall väl stå för relativa ra hastigheten längs ekliptan. Hög hastighet medför korta pulser, låg hastighet långa pulser. Om hastigheten är för låg så kanske avvikelsen hinner bli för stor innan felet hinner regleras bort. Samtidigt kan nog för hög hastighet ge instabilitet. Kommer inte ihåg vad jag satt mina värden till, men de flesta har sina defoultvärden. Maximalt tillåten pulslängd har jag dock ökat.

Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-09 09:31:41

Hej igen Lars

Det jag gått efter vid inställningen av Autoguide rate är det som står att läsa i diverse instruktioner till PHD.

Det enda jag tror jag kan styra ifråga om pulser i PHD2 är deras max längd. Hur korta pulser som kan genereras har jag inte läst någonstans och jag har inte läst ifall PHD alltid använder max tillåten hastighet vid korrigering.

Jag kanske skall sätta den på 0.75 så länge jag letar fel...


PHD2 – Guiding, Basic Use and Troubleshooting
Your mount, or mount driver may allow you to set a custom guiding rate. The best starting point is to set your guiding rate to 1x, which means that when guiding East the mount will stop completely, and when guiding West it will move at 2x sidereal rate. Many mounts offer 0.5x guiding rates (and others), which are helpful when hand guiding, but probably not that much use when using PHD. Keep it simple and use the 1x guide rate.

PHD2 - Best practices (av Bruce Waddington & Andy Galosso)
Mount Settings
Use guide speeds in the range of 0.5x – 1.0x sidereal

CGEM manual
Autoguide Rate – Allows the user to set an autoguide rate as a percentage of sidereal rate. This is helpful when calibrating your telescope to a CCD autoguider for long exposure photography.


/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-09 10:05:12

Hej Anders,
Nu kommer jag ihåg, jag har guide speed x1 vilket också var defoult värdet.

Max puls längden ställer du i EQMOD, inte i PHD. Däremot kommer varning från PHD om pulslängden inte räcker till. Jag får varningar, mest i de fallen då jag slarvat med polinställningen så att guidningen får jobba mer, även glappet i DEC påverkar ju guidningen om det är dåligt justerat.

Pulslängden (under max värdet) räknar PHD ut under en av inställningarna. Du trycker på en knapp och så räknas det ut, antagligen skall det vara kalibrerat innan och då kanske lämpligen kalibrerat längs ekliptan. Om du inte är nöjd med det värdet skriver du över det.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-09 11:04:22

Hej igen Lars

EQMOD verkar tyvärr inte ha stöd för Celestrons monteringar. I mitt fall styr PHD2 montering genom ASCOM utan inblandning av andra program, även om jag kan använda program som Nexremote och exempelvis Stellarium mellan ASCOM och PHD2.

Pulslängden som PHD2 räknar ut under Guiding-fliken, om det är den du menar, gäller endast under kalibreringen och beror bland annat på fokallängd, pixelstorlek och hur många steg west respektive north man vill att kalibreringen skall bygga på. Under aktiv guiding skickas pulser i olika längd mest hela tiden. Längden på dem motsvaras av höjden på staplarna i guidinggrafen och skrivs även ut i ms nere till höger i listen när de sänds.

Angående guiding speeden så fortsätter jag då med 1.0x…


/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-09 11:54:51

Hej Anders,
Hur är det ihop kopplat, går det via handterminalen eller direkt till monteringen?

Det finns inget inlagt via handterminalen som begränsar PHD reglering? Max pulslängd, max speed, min move etc

Ser på en tidigare bild att min move är ganska lågt på 0.2, är det automatiskt ditlagt eller har du lagt till det manuellt?

Hysteres =0.1, men antar det betyder 10%

Kan du lägga upp bilden på hur reglerparametrarna gudie algorithms är inställda?

https://openphdguiding.org/manual/?sect ... rithms.htm

För mig känns det ändå lite grann såsom det blir när jag har för låg fps, typ 2 sek istället för 1 sek. Men svårt att jämföra eftersom du har mer än dubbla fokallängden.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-09 12:34:31

Min setup är Guidekamera-Laptop-Handkontroll-Montering. Det enda jag tror KAN begränsas med handkontrollen är Autoguide Rate och lite maxvinklar.

När man kör PHD2 Guiding Assistant en bra stund, så hinner PHD2 få en god uppfattning om bland annat vad minimum move bör vara. Rådet från PHD2-teamet är att följa de rekommendationerna man får av GA, så siffrorna du ser är föreslagna av programmet. Exponeringstiden rekommenderas man att hålla mellan 2 och 4 sekunder. Med för korta exponeringar är risken att man jagar Seeing och med för långa att driften hinner bli för stor.
Aggression och hysteresis i RA är de enda inställningarna jag fiddlat med. På Algorithm-fliken finns inte mycket mer att göra:

Capture.JPG
Capture.JPG (27.92 KiB) Visad 1746 gånger



Jag gjorde lite justeringar i monteringen tidigare i veckan och hann som längst köra en guidning i 11 minuter innan moln störde. Den guidningen visade i alla fall en liten förbättring mot de första jag postade här.

Jag behöver bättre väder…


/a
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Periodiska fel

Inläggav AstroFriend » 2017-11-09 12:59:05

De ser ganska lika de värden jag har vad jag minns. Har ju ändrat många gånger i min utrustning som också föranlett jag fått ändra i PHD2, men nästan alltid har de automatiska parameteruppsättning fungerat mycket bra.

När jag tittar återigen på din bild som jag då antar inte har PEC aktiverat.

1 november 2017, 17:54

Så ser man hur pulserna (blå RA) kommer i massor utan att felet börjar gå tillbaks förrän efter ett tag och då har felet hunnit bli stort. Vet inte riktigt hur långa pulserna är om de möjligen maxar på 2500ms som du satt.

Med högre hastighet på motorn så skulle det hinna korrigera fortare, men om du redan har x1 känns det konstigt om det inte skulle räcka, är ju trots allt dubbla hastigheten framåt eller helt stop bakåt, enligt den texten du bifogade. Men man kan ju lätt räkna ut hur mycket fortare motorn måste gå med ledning av den oguidade kurvan. Från botten till topp på tiden, ger derivatan av hastighetens förändring, typ hur många bågsekunders förändring per minut jämfört med normaltiden. Får med lite huvudräkning att RA normal hastigheten borde vara 15' per minut eller 900" per minut och så stora är ju inte dina avvikelser. Snarare 30" på 4 minuter eller 7" per minut, det är ju bara 1% hastighets avvikelse. Kolla mina beräkningar, kanske blev helt fel.

Men klart skulle det nu vara något mekaniskt fel spelar det ju ingen roll hur man försöker, men kurvan ser ju jämn ut på de exempel du gett där guidningen är urkopplad så känns inte som det.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Användarvisningsbild
micke187
Inlägg: 584
Blev medlem: 2015-04-30 14:23:53
spamtest: JA
Ort: Säffle

Re: Periodiska fel

Inläggav micke187 » 2017-11-10 10:05:30

Tänkte Bara höra hur mycket viskositeten i fettet man använder till monteringen har för betydelse? Har själv lite bekymmer med guidningen att ra axeln inte riktigt vill vara med. Fettet jag använder är från biltema och känns lite trögt och kanske lite klibbigt men fick tips att använda det ändå. Har sett att superlube är det bästa att använda dock. Kan det göra skillnad tro att byta ut mot mindre visköst fett?
SXvr H-18mono
TS-optics photoline 80mm triplet
TS-optics photoline x0.79 R/F
Arduinostyrd fokuserare med Nema17 motor
Heq5 pro Rowan mod
50mm guidetub ,Qhy5l-ii
Program:APT ,PHD2
DSS,Nebulosity,PS,Startools
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: Periodiska fel

Inläggav dragneg » 2017-11-10 11:28:30

micke187,

Jag använder Superlube och den senaste demonteringen och justeringen i veckan bestod bland annat i att jag tvättade av ordentligt och därefter, med tandborste, applicerade ett knappt synligt lager fett.
Min tanke är, eftersom där varken finns stora krafter eller höga temperaturer, att det bara handlar om att helt rena metallytor inte skall ligga mot varandra. Som jag skrev ovan så upplevde jag en liten förbättring under de 11 minuter jag hann med att guida innan molnen kom…

Aningen för mycket fett med fel viskositet måste ha inverkan på precisionen.


Med Ring Gear rengjord tittade jag också på ”slitytorna” på kuggarna, alltså det "worm gear contact pattern" som Fredrikdb föreslog 3/11.
På närmare en tredjedel av varvet ”svängde” märkena fram och tillbaka över kuggarna. Denna del har jag nu markerat och kommer hädanefter se till att sätta mittemot Worm Gear vid uppstart av monteringen. Får se ifall jag kanske kan få ett lite jämnare periodiskt fel efter det.



Lars,

Jag har funderat på det du skrev ovan om hur pulserna ”kommer i massor”.
I PHD2 ser jag ju hela tiden vilka pulser som ges och i vilken riktning, och jag har aldrig sett längre än tre-siffriga pulser. Ifall 2500ms inte skulle räcka, hade väl förmodligen just så långa pulser synts mer frekvent. Dessutom borde ju höjden på pulserna i grafen oftare vara lika höga.
Capture.JPG

Ett utsnitt ur samma session som du refererade till, visar runt kl.22:38 mycket riktigt flera pulser i samma riktning utan att det resulterar i en vändning. Snabbare justeringar, längre pulser, högre aggressivitet känns spontant som att det borde kunnat fått kurvan rätt fortare, men jag tror inget av det är något jag kan påverka. Aggressiviteten var just där satt till 100% och Hysteres 10%.

/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D

Återgå till "Monteringar"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst