Intressant darkframe...

Digitala systemkameror (ej vanliga digitala med fast optik)
magnuslar
Inlägg: 272
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Intressant darkframe...

Inläggav magnuslar » 2016-03-28 20:55:39

Hej!

Jag håller på att få en lite äldre Canon 350D att bli min standardastrokamera - den är moddad hos Astronomiser och nu försöker jag få den att fungera på alla möjliga sätt - och det går framåt...:)

En lite underlig sak, dock, är mina darkframes. Jag har tagit en lång serie på 300 sek när det varit ljust, och trots att jag täckt fattningen med ett linslock och tejpat över sökaren, så är det nån slags ljust fält på dem. Nu på kvällen, när det inte finns så mycket ljus som kan komma in och också är lite kallare (om nu det spelar roll?) så ser de ut så här (när jag har stretchat och haft mig i PI, men autostretchen ser minst lika illa ut - jag förväntande mig lite heta pixlar men ingen sån blobb som nere till höger...:

Dark_301.jpg
Dark_301.jpg (226.23 KiB) Visad 1643 gånger


Vad kan det här handla om? Är det nåt som är fel på kameran? Och hur kan det komma sig att den är större på dan - kan det vara ljusläckage på nåt sätt?

Magnus
Starsoft
Inlägg: 1484
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: Intressant darkframe...

Inläggav Starsoft » 2016-03-28 21:46:50

Hej

Jag gissar på ett temperaturberoende artefakt, om fenomenet är konsekvent så borde det försvinna vid kalibreringen om du har hyfsat samma temperatur som när du tog kalibreringsbilderna. Om du testar att kyla kameran i kylen eller frysen så borde det framgå om det är ett värmerelaterat kamerafenomen.

Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
Tompa
Inlägg: 1379
Blev medlem: 2010-08-25 15:34:01
spamtest: JA
Ort: Borlänge
Kontakt:

Re: Intressant darkframe...

Inläggav Tompa » 2016-03-28 22:33:44

Tror som Anders, att värme är boven. Någon form av elektronik nära sensorn som sätter spår. Det försvinner säkert när du dark-kalibrerar.

Mvh,
Tomas W
-----------------------------------------------------------------
Bildblogg: http://ienannandelavrymden.wordpress.com
-----------------------------------------------------------------
Martin F
Inlägg: 1461
Blev medlem: 2013-11-06 12:16:53
spamtest: JA

Inläggav Martin F » 2016-03-28 23:57:12

Kör du med batteri eller adapter? Det gör stor skillnad för uppvärmningen.

Skickat från min E5823 via Tapatalk
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Intressant darkframe...

Inläggav AstroFriend » 2016-03-28 23:59:07

Hej Magnus!
Det är ingen fara, helt normalt på äldre kameror. Det kallas för ampglow. Ett ljus som sensorns förstärkare sänder ut när den är spänningssatt och den sitter just där du har ljusfläcken, bör inte påverkas nämvärt av temperaturen, däremot iso och exponeringstid. Men eftersom även bilden du tar ger en likadan ljusfläck försvinner den när du gör en darkcalibration. Modernare kameror stänger av spänningen till förstärkaren under exponeringen och därmed reduceras detta problem kraftigt. Kommer inte ihåg om det är från 400D eller 450D man tar till åtgärder för detta.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
Starsoft
Inlägg: 1484
Blev medlem: 2007-09-20 14:21:00
Ort: Gävle
Kontakt:

Re: Intressant darkframe...

Inläggav Starsoft » 2016-03-29 00:58:40

Hej

Jag tänkte också på ampglow men jag trodde inte det problemet fanns även för cmos sensorer, för det är väl en sån i den kameran?

Anders
Observatorium v2.0: http://www.hemlin.se/astroweb
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Intressant darkframe...

Inläggav AstroFriend » 2016-03-29 01:35:42

I regel är förstärkaren på en CMOS sensor på samma chip som själva sensorn därav problemet då den inte har någon kapsel runt sig. På en CCD är det i regel en separat kapslad krets och den släpper ju inte ifrån sig något ljus, ja förutom då IR om den blir varm men inte i de våglängdsområdena som sensorn är känslig.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu
magnuslar
Inlägg: 272
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: Intressant darkframe...

Inläggav magnuslar » 2016-03-29 08:14:01

Hej!

Tack!! Belysande!

Jag kör just nu med batteri. Nät-del är på ingående. Hur påverkar det?

Amp-glow, okej, det var nytt för mig. Och det känns ju bra att det inte är nåt fel. Men det här verkar faktiskt variera, det var betydligt större under dagen än under kvällen, när den här bilden är tagen. Om det sen är temperatur eller nåt annat återstår väl, med lite experiment i kyl och frys.

OM det nu varierar med temperatur eller annat, så antyder kanske det att det är viktigt här att ta nya darks varje gång jag tar lights, så de verkligen är rätt? Den här effekten verkar ju inte direkt linjär över hela bilden, och kan väl då inte hanteras av skalning i PI (som jag förstått att exponeringstid och temperatur annars kan hanteras, åtminstone delvis)?

Magnus
Martin F
Inlägg: 1461
Blev medlem: 2013-11-06 12:16:53
spamtest: JA

Inläggav Martin F » 2016-03-29 08:31:02

Batteriet blir varmt vid långa exponeringar så sensorn blir indirekt också varmare vilket ökar bruset.

Skickat från min E5823 via Tapatalk
hbar
Inlägg: 430
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Intressant darkframe...

Inläggav hbar » 2016-03-29 09:22:38

Eftersom temperaturhöjningen som ampen ger blir olika beroende på vilken temperatur sensorn och dess infästning har samt hur länge kameran varit påslagen (om den stabiliserats) så är det svårt att ta bort helt.

Jag skulle föreslå att du tar några darks innan och några darks efter en exponeringsserie. När du sen medelvärdesbildar dom så får du något som stämmer hyfsat.

Detta problem fixades på modell 400d o senare. Drabbades själv av det på en Atik ccd kamera. Tog ett tag innan jag fick reda på att där var en bug i drivrutinen som gjorde att om man använt snabb utläsning för att ställa fokus så glömde programmet att stänga av förstärkaren och efterföljande bilder drabbades.

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
AstroFriend
Inlägg: 4069
Blev medlem: 2012-12-17 13:30:45
spamtest: JA
Ort: Stockholm
Kontakt:

Re: Intressant darkframe...

Inläggav AstroFriend » 2016-03-29 10:59:06

Själva ampglowen bör ju inte vara temperaturberoende. Men om du jämför darks som är tagna vid kyla resp. varm väderlek så kommer de varma ha mer brus och då kanske det visuellt ser ut som ampglowen är lägre eftersom den maskeras av det termiska bruset, bara en ide.

Du behöver inte ta nya darks varje gång, men däremot skall du ju försöka ha ett bibliotek för varje temperatur, exponering och iso inställning. Sätt en termometer fast mot kamerahuset så får du i varje fall en grov uppfattning om kamerasensorns temperatur. De nyare Canon kamerorna, de med liveview har inbyggt temperatur sensor i kamerahuset som gör det lättare.

Jag har på min hemsida en tutorial om hur man i det fallet kan gå tillväga:
http://astrofriend.eu/astronomy/tutoria ... canon.html

En CCD med aktiv kylning kan kanske som bäst hålla temperaturen inom några hundradelar av en grad. Så bra kan man inte göra med en DSLR, kanske man kan ha ett bibliotek med en uppsättning för var tredje grad om man har bra kontroll på temperaturen. Jag brukade ta 55 subdarkar för varje temperatur där jag kastade de första 5 eftersom kamerans temperatur inte hunnit stabilisera sig då. Alternativ kan man ju bara låta kameran gå över hela natten och då varierar temperaturen och efteråt är det bara att sortera upp de i olika temperaturintervall. Fast kräver då den nyare typen av kamera med temperatursensor. OBS temperatursensorn mäter kamerahusets temperatur inte sensorns vilket är en begränsning.

Att skala darks för olika temperaturer är nog som du säger inte en bra ide när man har ampglow, borde inte fungera.

Numera tar jag inga darks alls utan använder mig av dithering samt sigma clipping. Du kan ju prova med det på din kamera, med tillräckligt stora dithering förflyttningar kanske det går att hantera ampglowen, men tror det är svårt.

Har skrivit om dithering på min hemsida:
http://astrofriend.eu/astronomy/tutoria ... ering.html

Batteri:
I början hade jag batterieliminatorn inbyggd i batteriet på min kamera, ingen bra ide, värmde upp kameran. Med extern omvandlare blev det perfekt.

Även om man använder batteriet direkt så blir det ju lite värme av det när kameran arbetar som påverkar sensorn från förlustvärmen, men inte jättemycket vad jag kunnat erfara. Finns ju en liten risk med en batterieliminator också, kablarna kan fastna samt att elektroniken i den kan störa kameran och ge mönster i bilderna.

Nu är ju dock en Canon 350D en populär kamera än idag och kan leverera bra bilder så man kanske inte skall förkasta kameran bara för detta. Jag var mycket nöjd med min.

/Lars
Camera: Canon EOS 5D/6D
Mount: EQ6
Telescope: TS130 APO
Samt en massa tålamod!

Homepage: http://www.astrofriend.eu

Återgå till "DSLR-kameror"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst