PixInsight-problem

Metoder för astrofotografering
MartinS
Inlägg: 197
Blev medlem: 2016-06-26 13:33:40
spamtest: JA

Re: PixInsight-problem

Inläggav MartinS » 2019-05-01 19:10:45

Har du testat att stacka exakt samma subbar och kalibration frames som ger dig problem med DSS? Kan ju ringa in problemet till PI i all fall.

När det gäller STF så kan du tex testa att kalibrera en flat frame med din master flat. Detta gör att bilden får nästa samma värde över alla pixlar. Kör sedan en auto STF på den och det kommer dyka upp massa brus och eventuella mönster som inte gick att se efter STF med din flat sub som inte är kalibrerad. Eftersom bilden är mycket "jämnare" kan STF stretcha mycket mer utan att klippa svärtan.
magnuslar
Inlägg: 317
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-01 19:34:49

Hej!

Jag är inte med på det du skriver om STF. VIlken roll skulle STF spela -det är ju bara för hur det ser ut på skärmen, den påverkar inte själva bilden. Min bild som jag postade här är t ex stretchad med Histogram. STF spelar ju ingen roll för den "riktiga" stretchingen"?

Däremot är jag med på att "black point" spelar roll, eftersom det här är mörka stråk. Man kunde tro att de är "avklippta". Min bild dock, där verkar inte ens de mörka stråken vara på noll i "rått" skick, så knappast klippta i kalibreringen.

Magnus
Användarvisningsbild
dragneg
Inlägg: 59
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-01 20:32:26

Jag noterar att mina försök att stacka 180 bilder, 60 från varje natt, ger samma linjer oavsett om jag använder viktning genom Noise evaluation eller genom Subframe Selector (FWHM, ECC, SNR). Även en bild bestående av så få som 15 per natt ger samma effekt. Förutom streck blir ju bilden då också brusigare...

De separata stackarna från de tre nätterna är ju alla var för sig utan streck. De består av 240, 219 respektive 168 bilder. Mängden bilder har alltså ingen inverkan, utan strecken framträder endast vid integrering av de olika nätterna.



Jag har inte testat DSS och har aldrig hunnit lära mig det. Kan naturligtvis vara en intressant jämförelse.
Tyvärr har jag inga Flats kvar. Tog bort samtliga efter att jag gjort Masterflatten. Eftersom jag inte rörde någonting mellan nätterna tog jag flatsen första kvällen och använde sedan samma master för alla tre kalibreringarna.


Magnus, är det inte så att om jag ”STF:ar sönder” en bild och därefter stretchar den med HT så är det så som den såg ut som den blir? Om jag inte förstår funktionen av STF bättre, utan ”låter” STF screenstretcha bilden ”mer än den tål”, så får jag med mig det felet därefter. Eller?
Var det så du menade ovan Martin?
När ditt SNR går upp skulle man kunna tänka sig att PI kan göra auto stretch lite hårdare och på så vis så kan strecken dycka upp.


/anders
Celestron EdgeHD 8" , Sky-Watcher ESPRIT-100ED , i-Optron CEM60EC , ZWO ASI294MC Pro , Canon EOS700D
MartinS
Inlägg: 197
Blev medlem: 2016-06-26 13:33:40
spamtest: JA

Re: PixInsight-problem

Inläggav MartinS » 2019-05-01 20:33:44

Är fullt medveten att STF inte påverkar bilden och menar egentligen Histogram Transformation. Om man ska jämföra bilder är det ju viktigt att man gör samma stretch på alla. Om man t.ex. trycker på auto stretch i STF och sedan kopierar över det till Histogram trans. så skall ju en och samma stretch appliceras på alla bilder man vill jämföra.

Beroende på vilket värde de mörkaste pixlarna har så kommer ju blackpointen att hämna på olika ställen när man trycker auto stretch. Min teori var att när man ökar integreringstiden så kanske autostrech i STF flyttar blackpointen "upp" vilket ger mer konstrast och saker som tidigare var dolda pga lägre kontrast (+brus) kan bli synliga.

Jag gjorde själv nyligen tester med flats som jag tagit med en LED panel. När jag jag stretchade individuella flats-subbar såg de fina ut. Efter att jag kalibrerat en flat-sub med master flats och "autostrechade" kunde man tydligt se bandningsproblem i mina subbar. Detta var en effekt av nätagget till led-panelen som ej gav konstant DC matning.

Nu är ju inte detta någon bandning utan verkar vara något annat konstigt som händer.
Användarvisningsbild
kribba
Inlägg: 585
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-05-01 20:39:08

Provade att strunta i bias med BPP i Pix på en problem bild med Rosette. Ingen skillnad mot med bias. ASI1600MCpro
Bilagor
asi.jpg
asi.jpg (78.63 KiB) Visad 309 gånger
William Optics ZenithStar II 80mm, Celestron C6 SCT, SkyWatcher NEQ6, ASI 1600MC, Canon 600Da, EF 200mm 2.8, EFS 15-85mm, Pixinsight, Photoshop CC
magnuslar
Inlägg: 317
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-01 21:00:53

Kribba, har du dither på när du tagit dem?

Även om jag inte fattar hur, känns det som att det skulle vara en dither-effekt är mest troligt. Men så har ju du Anders ingen dither....? Så vi har exempel på dessa stråk både med och utan dither?

Vad annat skulle kunna skapa såna mönster? Banding eller som min kamera, heta pixel-rader är ju inte snett utan följer pixel-matrisen på chippet.

Magnus
SvenP
Inlägg: 53
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-05-01 21:22:33

Jag hittade ett par bilder från början av april då jag testade min Skywatcher 120 ED med 294 mcpro. Samma objekt men kameran roterad mellan tillfällena.
Den första stacken (19 subbar a 180 sek gain 61) har kraftiga diagonala strukturer och vignettering subbarna hade lågt SNR värde. Den andra stacken (26 subbar a 180 sek gain 120) har subbar med betydligt högre SNR-värde.
Standardinställningar från STF överförda via HT.
Beträffande linjerna har jag prövat allt jag föreslagit, inget hjälper. Inget tycks synas i de enskilda subbarna men linjerna ser ut att stärkas ju fler subbar jag tar med vid integreringen. Ingen dihtering har förekommit och jag också försökt utan att använda flats men ingen skillnad vad avser linjerna.
Låg gainsättning ska ju öka utläsningsbruset, dock vet jag inte hur sådant brus ter sig.
/SvenP

TEST.jpg
TEST2.jpg
Användarvisningsbild
kribba
Inlägg: 585
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-05-01 21:25:56

Nix är inte diether. Är kört med 200mm lins utan guide teleskop. Stackar jag enbart lights så hamnar jag här
Bilagor
L.jpg
L.jpg (56.71 KiB) Visad 302 gånger
William Optics ZenithStar II 80mm, Celestron C6 SCT, SkyWatcher NEQ6, ASI 1600MC, Canon 600Da, EF 200mm 2.8, EFS 15-85mm, Pixinsight, Photoshop CC
magnuslar
Inlägg: 317
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-01 21:53:25

Kribba, så intressant! Så vi kan helt glömma dither. Om du stretchar den där bilden ännu mer, den stackade utan att de är kalibrerade - dyker det upp nåt liknande då?

Magnus
magnuslar
Inlägg: 317
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-01 21:55:03

Sven: i den andra av dina två bilder ser jag inga linjer... ska det vara linjer där? Är den alltså kalibrerad med flats (ingen vinjettering)?

Magnus
SvenP
Inlägg: 53
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-05-01 22:14:47

Bilderna från den 10 resp 11 april. Det ska inte vara linjer i den andra bilden, den är ok bortsett från att man kan ana lite färggradienter i bakgrunden men de försvinner med lite mindre strectch och om man gör ABE på en stack som är splittad på de olika kanalerna. På den första bilden hjälper inget mot linjerna annat än en extremt låg stretch. Jag har nu provat att stacka subbarna i Images+ också men linjerna är kvar så inget fel på PI.
Bilderna från första dagen är tagna med gain=61 och förhållandena var inte så bra så SNR blev betydligt lägre än dag 2 då gain var satt till 120.
Jag har ingen ok masterflat till första bilden men det har ingen inverkan på linjerna.

/SvenP
Användarvisningsbild
dragneg
Inlägg: 59
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-01 23:35:08

“STF Parameters” skiftar stort mellan bilder. Det är väl detta du menar Martin? Tyvärr har jag inte tillräcklig kunskap om bildbehandling för att förstå...

Om jag kör en STF på integreringen från den första natten så blir värdena enligt nedan.

21.JPG


Värdena på stacken från alla tre nätterna blir dessa:

212223.JPG


Om jag ställer in de förra på den senare blir resultatet följande:

212223b.JPG


Och om jag ställer in de senare på den första blir det så här:

21b.JPG


Inga linjer synliga någonstans...




Men, frågan kvarstår, varför är strecken parallella? Jag tror att ifall vi finner svaret på det, så har vi förmodligen också svaret på vad man kan göra åt det. Jag tycker det måste handla om matematik och nån typ av interferens. Jag undrar ju så här efteråt vad som skett om jag vridit kameran 90 grader vid något tillfälle. Hade linjerna följt med?
Jag noterar att en stack på 45 av mina bilder tagna vid tre olika tillfällen har svagare streck än 625 bilder, men också att 240 från ett och samma tillfälle helt saknar streck. Att Sven får samma resultat i annat program frikänner ju PI. Att Gain skulle avgöra är föga troligt, då samtliga mina bilder är tagna med Unity Gain på 120.

SNR kvarstår...vad är ett högt SNR och vad är lågt? Går det att säga?

Mitt högsta är från andra natten en stund efter midnatt, 2.3466. Är det värdet relativt eller absolut? Kan jag jämföra det med SNR på Svens bild?

Mina SNR låg mellan:
1.6387 och 1.9552 första natten
1.7157 och 2.3466 andra natten
1.6000 och 1.6697 tredje natten

Kan det spela någon roll om det skiljer mycket mellan högsta och lägsta SNR?
Mellan min högsta och lägsta under första, andra och tredje natten: 19%, 37%, 4%. Mellan högsta och lägsta SNR mellan alla tre nätterna: 47% !!!

Tittar jag på bilderna i mitt inlägg från 23:46 igår, så ser faktiskt den värst ut som består av andra och tredje natten, det är också den med störst diff. Bruset i de enskilda bilderna leds faktiskt av natt nr.2 som har störst diff i SNR.

Skulle ovanstående spekulationer ha någonting med verkligheten att göra, så kvarstår ändå fortfarande frågan; Varför är linjerna parallella? Varför blir det inte bara mer brus...

/a
Celestron EdgeHD 8" , Sky-Watcher ESPRIT-100ED , i-Optron CEM60EC , ZWO ASI294MC Pro , Canon EOS700D
MartinS
Inlägg: 197
Blev medlem: 2016-06-26 13:33:40
spamtest: JA

Re: PixInsight-problem

Inläggav MartinS » 2019-05-02 09:48:16

Aah, och det verkar som att första bilden har betydligt ljusare bakgrund. Tänkte inte på att det givetvis blir så när man kombinerar olika nätter.

Men häng inte upp dig för mycket på stretchande. Det är ju inte roten till problemet.

Jag hade testat att stacka i annat enklare program som dss. Har tyvärr dåligt med tid de kommande 2 veckorna men om du inte kommer vidare kan jag hjälpa dig att göra ett test i DSS vid senare tillfälle.

Om samma problem dyker upp där är det ju något som är fel med din data eller kalibrering.

Om inte så är det någoN setting eller problem med PI. Visar det sig att så är fallet, så hade jag gjort en tråd på pixinsights forum.

Med den mängd tester du gjort så borde du kunna få lite feedback från deras utvecklare eller annan kunnig person på forumet.
SvenP
Inlägg: 53
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-05-02 16:05:33

Jag har nu testat att stacka mina 21 subbar även i DSS. Samma strukturer dyker upp. Nu är jag dock tveksam om de är diagonala eller cirkulära med en relativt stor radie. Vidare så är det svårt att upptäcka strukturerna i en enskild sub. Hos mig blir de tydliga först efter integrering av 5 subbar. För Anders del ser de ut att bli synliga först efter integrering av flera hundra. Svaga strukturer (signaler) framträder ju tydligare vid stackning.
Jag har också provat att stacka med min resp max i stället för medel och då syns de lite mindre men finns likväl där. Även stackat utan debayer.
Eftersom de inte heller går att kalibrera bort så måste det rimligen röra sig om ett tillfälligt optiskt fenomen av något slag eller ett tillfälligt fel på kameran.
Jag funderar på om kylningen på ett eller annat sätt kan vara boven, d.v.s. att det bildas någon lätt kondens eller små iskristaller ibland och vilka skulle kunna orsaka något sådant här fenomen. Sensorkammaren är ju försedd med torkmedel (som dock blir mättat till slut)) men för skyddsglaset har jag inte använt något kondensskydd . Jag har dock ZWO:s egna värmeband för kameran men jag har aldrig tyckt det varit nödvändigt att ha det på vid mina balkongsessioner.

/SvenP
Användarvisningsbild
kribba
Inlägg: 585
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-05-02 16:15:21

Har du provat och bara stacka lights Sven?
Då försvinner ju felet hos mig iallafall. Tar
jag bort bias så händer inget. Så rimligen bör
det ha med darksen att göra.
William Optics ZenithStar II 80mm, Celestron C6 SCT, SkyWatcher NEQ6, ASI 1600MC, Canon 600Da, EF 200mm 2.8, EFS 15-85mm, Pixinsight, Photoshop CC

Återgå till "Metoder & bildbehandling"

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst