PixInsight-problem

Metoder för astrofotografering
Användarvisningsbild
kribba
Inlägg: 661
Blev medlem: 2017-02-10 13:07:50
spamtest: JA

Re: PixInsight-problem

Inläggav kribba » 2019-05-02 19:29:56

Här är resultatet när jag stackar ngr snabba testbilder jag tog i början av augusti förra året på Vail med då nya 200mm gluggen i Ha.
Överst är full kalibrering och nedan enbart stackade lights. Har en känsla av att felet minskar med ökad SNR.
Bilagor
vail2.jpg
vail2.jpg (131.15 KiB) Visad 729 gånger
vail1.jpg
vail1.jpg (130.89 KiB) Visad 729 gånger
Kommande SDST i Extremadura Spanien. Blandade teleskop, kameror och monteringar hemmavid.
Robert Habolin
Inlägg: 814
Blev medlem: 2014-05-04 13:21:54
spamtest: JA
Ort: Färjestaden

Re: PixInsight-problem

Inläggav Robert Habolin » 2019-05-02 20:39:24

Jag hade detta problem nyligen... det var mina darks, tog nya så va problemet borta! måsta givetvis ALLTID vara samma exp tid och temp som lights. jag kör alltid Batch pre-process.

TS RC-8 PRO, Sesto Senso motorfokus, Lodestar X2 guider, 27mm OAG
TS N-AG8 Astrograph, Lakesside motorfokus, SSAG guide package
EQ6-R Pro
Sbig St-8300m FW8-8300, Astrodon filter.
MaximDl, Pixinsight, Photoshop
magnuslar
Inlägg: 322
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-02 21:03:45

Hej!

Robert, så vad är skillnaden mellan dina nya och gamla darks? Samma nivåer? Samma noise-levels osv...?
Har du möjlighet att posta dem i fits eller xisf-format så man kan kolla? Om det försvinner med olika darks måste de ju ha olika egenskaper - då kanske vi kan förstå vad "felet" handlar om och/eller orsakas av.

Mvh

Magnus
SvenP
Inlägg: 57
Blev medlem: 2017-07-07 16:20:36
spamtest: JA

Re: PixInsight-problem

Inläggav SvenP » 2019-05-02 22:03:17

Ja Kribba jag har provat med att stacka enbart lights, "ränderna" finns där ändå.

/SvenP
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-09 11:36:25

Jag postade, som föreslaget frågan på PixInsight Forum och fick svar som jag känner fullständigt förklarar mitt problem - ”Walking Noise”, också kallat ”Correlated noise” eller ”Raining noise”.

Anledningen, som jag förstår, är en mycket liten drift i streckens riktning och guidningens korrektion tillbaka. Driften är förmodligen på grund av monteringens PA eller rent av hastigheten i RA jämfört jordrotationen, kombinerat med avsaknaden av Dithering eller en för snål Dithering.

En egen reflektion är att en stor mängd exponeringar förvärrar problemet i stället för att reducerar det, vilket jag trodde och därför tog 500-600 st under tre nätter...

Vad tror ni?

/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
Martin F
Inlägg: 1670
Blev medlem: 2013-11-06 12:16:53
spamtest: JA

Re: PixInsight-problem

Inläggav Martin F » 2019-05-09 12:47:49

Köper det rakt av. Hade mycket sånt i mina DSLR-bilder innan jag började med dithering. Försvann helt efter att jag börjat köra det.

Skickat från min E5823 via Tapatalk
magnuslar
Inlägg: 322
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-09 15:10:09

Hej!

Hrm.... förklarar dåligt mina ränder. Jag kör med dithering, och det här är bara på vissa, varför inte alla då....?

Har du länk till tråden? Jag lyckas inte hitta den på Pixinsight Forum.

Magnus
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-09 19:42:23

Hej...

Mitt PI-inlägg finns här: https://pixinsight.com/forum/index.php?topic=13597.0 Inga långa uttömmande svar, men det gav mig ett namn på problemet så jag kunde söka vidare. Jag är övertygad om att Dithering var mitt problem den här gången.

Ett annat inlägg jag hittade: https://www.dpreview.com/forums/thread/4159947

Post 5 i denna tråden är också intressant: https://www.cloudynights.com/topic/597992-will-dithering-help-with-this-noise-problem/ Han pekar på ytterligare en orsak...

/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
hbar
Inlägg: 509
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: PixInsight-problem

Inläggav hbar » 2019-05-10 09:51:48

Anders, jag håller absolut med det som skrivs i posts 5. Jag har konstruerat mycket optoelektronik som konsult och detta beskriver de problem vi har hittat i våra mätinstrument.

Skulle vilja tillägga att ditering kan ge samma problem som flex (och därmed framkalla och inte lösa) om denna inte är helt random i positioneringen. Tänk dig att du genererar en diter-ofs i steg om väst, norr, öst o sen syd. Lätt att inse om man kommer tillbaka till samma position med en lite ofs från ursprungliga så kommer en het pixel att generera 4 st prickade linjer.

I våra interferometrar så medelvärdesbildas samma signal kanske 10 000 gånger för att sänka bruset en faktor 100 (behövs när man skall mäta bråkdelar av ppm med massor av atmosfäriska störningar). Helt plötsligt dyker allt möjligt upp som initialt kan vara svårt att inse att det kan generera en icke random störning. Enkelt exempel, utläsning från en 16-bits ad-omv, tydlig störning vid nollgeneomgången (alla bitar slår om från 0 till 1).

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-10 20:18:43

Intressant Håkan… PHD2 använder Random Dithering, så det är ju bra.

Min M13 i denna tråd bestod av 582x60sek tagna under tre nätter, fotade med ASI294, utan dithering. Jag chansade på att den stora mängden bilder skulle göra dithering överflödigt, men anledningen till linjerna är ju nu självklar. Jag hade högst troligt nått ett mycket bättre resultat om jag nöjt mig med att bara få ihop hälften av antalet, som varit fallet om jag använt dithering, eftersom den nästan tar lika lång tid som exponeringen.



Den bästa jämförelsen jag har är nedanstående M31 som jag fotade jag i höstas. Den består av ännu fler korta exponeringar från fler olika tillfällen. 699x60sek, tagna under 10 nätter men MED dithering. Fotad med en EOS700D med DSLR:ens alla nackdelar. Där fanns ingen tillstymmelse till linjer eller andra artefakter, så det torde vara bevisat att dithering ”is da shit”

https://flic.kr/p/2bVsaYi



/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
hbar
Inlägg: 509
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: PixInsight-problem

Inläggav hbar » 2019-05-10 22:25:18

Jag har också en asi294pro och har aldrig anv dithering. På min bild av novan så har jag 50x2min
http://www.astronet.se/phpBB3/viewtopic.php?t=17950
Här är en kraftigt förstorad bild på bruset

n.jpg
n.jpg (61.81 KiB) Visad 593 gånger


Det syns inte heller något på Astrometrika som är känsligt för detta.

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-10 23:29:07

Ju fler bilder utan dithering, desto tydligare bör väl felet bli enligt resonemanget om anledningen till Walking Noise? Jag har 12x så många bilder i min streckbild än vad du har i din Håkan.
Jag testade ju stacka 168, 219, 240, 387, 408, 459 och 627 bilder. 387 och över uppvisar ganska tydliga streck. Antingen har strecken med antalet bilder att göra, eller med olika sessioner. Men jag har stackat flera nätter många ggr förut, utan problem. Exempelvis M31 ovan som består av tio nätter...

Har du någon bild stackad av 300+ Håkan?

Den 22/4 tog jag 240x60sek och även den stacken är ju som man kan se på bilden i inlägget 30/4 23:46:12 utan något regelbundet brus i bakgrunden. Så på en stack av endast den kvällens bilder så har jag svårt att se de linjerna man ser på stackarna av ännu fler.

Det ligger kanske fler orsaker bakom problemet?

/a
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D
magnuslar
Inlägg: 322
Blev medlem: 2014-12-22 10:41:51
spamtest: JA

Re: PixInsight-problem

Inläggav magnuslar » 2019-05-11 00:12:41

Hej!

Hrm. Mina ränder uppträder i OIII men inte Ha-bilder, tagna på exakt samma sätt. Samma exponeringstid, samma dither. Hur kan man förstå det då?

Magnus
hbar
Inlägg: 509
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: PixInsight-problem

Inläggav hbar » 2019-05-11 09:29:15

Ett enkelt sätt att testa om dither eller flex ligger bakom problemet är att stacka samma sekvens fixt (utan alignment). Ger stjärnorna upphov till ett mönster liknade bruset så är problemet hittat.

Finns mönstret bara under vissa förutsättningar men inte andra så gäller det att hitta vad som skiljer (när slumpen är borträknad), jag sa ju att det var svårt:). Är det flex så kan det variera beroende på var på himmeln teleskopet pekar.

Varje dubbling av antalet bilder som stackas förstärker det en faktor 2 (om det ligger i fas). Dvs man ser störst skillnad i början. Mönstret kan ha en periodicitet som gör att det framträder tydligare vid tex 10, 20, 30 men mindre vid 5, 15, 25. Inte så troligt men fullt möjligt.

Sen finns ju möjligheten att någonting i programmet ställer till det under vissa förutsättningar. Jag har inte lärt mig behärska det än utan anv fortfarande Nebulosity.

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
dragneg
Inlägg: 63
Blev medlem: 2016-09-05 16:55:40
spamtest: JA
Ort: Jonsered
Kontakt:

Re: PixInsight-problem

Inläggav dragneg » 2019-05-12 09:32:49

Testat och bevisat enligt Håkans förslag:

integration_u_r.jpg


Samma tre nätter, med totalt 582 bilder. Inte ett streck i bakgrunden! Faktiskt en sådan bakgrund jag skulle önska all bildbehandling startade med. Däremot ligger stjärnorna, mycket riktigt, i exakt samma riktning som strecken gjorde.

Din bild på novan, Håkan. Vad skulle du vilja "skylla på" där? Extrem PA eller en fantastisk montering? Jag ser i mina PHD2-loggar att jag under nätterna hade en PA-drift på 2.1', 2.7' och 2.9'



Det skulle vara intressant om du gjorde samma sak med dina oregistrerade OIII-lights Magnus, för jämförelse...

/anders
ESPRIT 100ED, Nexstar 8SE, EdgeHD 8", EdgeHD 11", iOptron CEM60EC, ZWO ASI294MC Pro, Canon EOS700D

Återgå till "Metoder & bildbehandling"

Vilka är online

Användare som besöker denna kategori: 17 och 0 gäster