Sida 3 av 3

Re: Motorfokus projekt

Postat: 2015-04-05 17:20:59
av Corpze
Nja... om min matte stämmer så får jag allt från 100 step/grad ner till 54 step/grad... och någon på 74 så jag känner mig för lätt och sätter 75 till att börja med, skall ta fler mätpunkter framöver.

Nu har jag ändrat windows sparfunktioner för USB-portarna iaf, men det är jättemärkligt detta med att ansluta.
Jag loggade in på obsdatorn för en timma sedan, FOcusMax var öppet sedan innan och tempen låg på behagliga 12 grader i vårsolen (skuggan) vilket stämmer rätt bra. Jag disconnectar FM och öppnar Optical Telescope Controller för att plita in temp koefficienten men nu kan den inte ansluta (error 5, com-port nånting franskt) Då öppnar jag USB_Focus manager och anger COM6, går hur bra som helst att ansluta. Jag byter till OTC-programmet och ingen anslutning :evil:
Jag startar om datorn och nu kan jag ansluta med OTC.

kanske låg den i sparläge på något vis ändå? Får vänta tills ikväll och prova, nu fungerar det iaf igen (det är ju repeterbarheten och driftsäkerheten man vill åt)

Re: Motorfokus projekt

Postat: 2015-04-05 21:59:16
av AstroFriend
Hej Daniel!
Att göra en perfekt temperaturkompensering genom att bara mäta temperaturen går inte, men mycket bättre än att inte göra någonting.

Hade det bara varit teleskopets aluminumtub som skulle kompenseras hade det kunnat bli ganska bra. Men nu består ju tyvärr teleskopet av flera olika aluminiumdelar med olika termisk tröghet. Dessutom är ju till ex. linserna av annat matrial, glas som termiskt är mycket tröga. Skall det bli perfekt blir det mer adpativ teknik man får tillgå där man kontinuerligt känner av fokusen och oberoende av temperturen. Men det ligger utanför amatörens möjligheter idag utom för den allra mest simpla tekniken.

När du mäter upp dina tempkalibreringspunkter är det bra om du kör fokusen bara åt ett håll så du slipper glappet när motorn växlar riktning.

Jag försöker läsa din beskrivning om USB problemen. Kan det vara så att du inte ansluter som administratör? Det är speciellt viktigt då flera enheter skall kopplas ihop via ASCOM. Det går att lösa på andra sätt, men har du möjligt att starta programmen som administratör så är det bäst ur den synpunkten.

/Lars

Re: Motorfokus projekt

Postat: 2015-04-06 08:47:27
av Corpze
AstroFriend skrev:Hej Daniel!
Att göra en perfekt temperaturkompensering genom att bara mäta temperaturen går inte, men mycket bättre än att inte göra någonting.

Hade det bara varit teleskopets aluminumtub som skulle kompenseras hade det kunnat bli ganska bra. Men nu består ju tyvärr teleskopet av flera olika aluminiumdelar med olika termisk tröghet. Dessutom är ju till ex. linserna av annat matrial, glas som termiskt är mycket tröga. Skall det bli perfekt blir det mer adpativ teknik man får tillgå där man kontinuerligt känner av fokusen och oberoende av temperturen. Men det ligger utanför amatörens möjligheter idag utom för den allra mest simpla tekniken.

När du mäter upp dina tempkalibreringspunkter är det bra om du kör fokusen bara åt ett håll så du slipper glappet när motorn växlar riktning.

Jag försöker läsa din beskrivning om USB problemen. Kan det vara så att du inte ansluter som administratör? Det är speciellt viktigt då flera enheter skall kopplas ihop via ASCOM. Det går att lösa på andra sätt, men har du möjligt att starta programmen som administratör så är det bäst ur den synpunkten.

/Lars


Ja tempregleringen får bli som den blir, bygger på med fler värden eftersom så det blir väl mer exakt framöver.
Fokuseraren körs inifrån och ut av FocusMax och när den satt V-kurvan kör den tillbaka till bästa fokuspunkt och finjusteras, och sedan tas tre testbilder för verifikation. Så den funkar bra. Gäller bara att använda en stjärna med magnitud 4-8 nånting, snarare 6-8 enl. Mig

Jag satte alla program som "kör som admin" nu och strömläget är helt avslaget i regedit, nytt försök hedanefter :)
Tyvärr verkar det som att Focus Manager - programmet är det som krånglat, för efter att jag anslutit med det programmet och kopplar ner så går det inte att ansluta med varken OTC eller FocusMax. Det går inte ens att ansluta med Focus Manager programmet igen efter jag gjort det en gång tidigare. Som att programmet, även om jag trycker på close, inte stänger anslutningen innan jag avslutar programmet.

Re: Motorfokus projekt

Postat: 2015-04-06 10:36:47
av AstroFriend
Hej Daniel!
Det där problemet med att det inte går att återansluta programmet känner jag igen i vissa situationertidigare. Tycker inte jag haft det sedan jag alltid kör som administratör. Dock för kameran, en Caon EOS 5D är det så. Tappar eller att jag stänger av kontrollen till den och efteråt kan det vara mycket svårt att få igång kontakten med kameran igen. Ibland går det om jag bryter strömmen till kameran, tar ur USB kabeln och väntar 10 till 20 sekunder. Jag tror de här problemen har något med windows att göra och hur det kontrollerar USB portarna. Har läst om andra som har liknande problem fast med helt andra utrustningar. Byter de till en ny USB port fungerar det igen, likaså för mig med kameran (ibland).

Anledningen till at du byter program för fokusmotorn, är det för att i focusmanager temperaturkompenserar du och i Fokusmax ställer du fokus? Jag använder antingen bara APT via ASCOM eller bara Focusmanager, det senare när jag skall temperaturkompensera. Just när man aktiverar ASCOM verkar de vara knepiga att avsluta exekveringen så kanske något med det. Titta i windows manager om Focusmanager ligger kvar där efter du kört det eller något annat som du skall ha avslutat. Jag skall också börja utnyttja den automatiska fokuseringen, verkar ju vara praktiskt. Men frågan om jag hinner få klart väder innan det blir alldeles för ljust. Bäst vore ju om du kunde aktivera temperaturkompensering i fokusmax så du slipper hålla på att byta program.

Överhuvudtaget verkar det här med USB inte vara en bra teknik, har haft mycket problem med det. Men på något sätt har jag alltid lyckats med lite knep komma förbi det.

/Lars

Re: Motorfokus projekt

Postat: 2015-04-06 13:18:41
av Corpze
Nej jag bytte mest program för att dubbelkolla inställningarna i Focusmanager och varje gång jag använde det programmet så kunde jag inte ansluta via något annat program efteråt, men nu är allt satt som admin och ej strömsparläge, så nu känns det lite mer stabilt, har haft focusmax igång i 14h utan problem nu och tempcompenseringen i FM fungerar också bra.

Ska testa mer under veckan...

Re: Motorfokus projekt

Postat: 2015-04-06 22:07:18
av AstroFriend
Hej Daniel!
Vad bra du inte behöver använda båda programmen. Då när du inte behöver skifta mellan dom lär det säkerligen fungera ganska smärtfritt.

Lycka till och hoppas vi får se en massa bilder!

/Lars

Re: Motorfokus projekt

Postat: 2015-12-08 20:42:27
av drobban
AstroFriend skrev:Jag har en liten lathund när jag arbetar med detta. Speciellt USB portarnas com port nummer brukar ändras och svåra att hålla reda på.


Nu var det ett tag sedan jag använde Windows (XP var den sista versionen), men vill minnas att det gick allokera fasta com-ports nummer. Kan ha fel, men har för mig att man gjorde det i enhetshanteraren klicka fram enheten i listan och sedan i egenskaperna för enheten.

//David Bern

Re: Motorfokus projekt

Postat: 2015-12-09 00:25:38
av AstroFriend
Hej David!
Jo jag kan ställa in vilken comport den skall ha, men det händer tyvärr att den ändrar den inställningen när man kopplar i och ur USB tillbehör. Speciellt skulle jag vilja kunna ge de olika USB tillbehören unika namn så jag vet vilken som är vilken. USB-Focus heter så på comporten men ingen annan har mer än numret. Antagligen ligger det i hårdvaran på USB-Focus.

/Lars

Re: Motorfokus projekt

Postat: 2015-12-09 07:47:17
av Quilding
Ja, det där med portnummer brukar vara olika beroende på hårdvara/drivrutiner. T.ex. FTDI FT232 får samma portnummer oavsett vilken USB-port man sätter den i. Den behåller alltså tilldelat portnummer även om man flyttar på den. Däremot Microchips PICar byter portnummer om man byter USB-port.

/Q