Får inte kontakt med SX filtersnurra

Programvara för astrofoto och bildbehandling.
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 15:23:12

Jag har köpt en ny laptop som ska ersätta en 8 år gammal minidator som bl.a. ska sköta ett Starlight Xpress filterhjul.
Båda datorerna kör Win 10 men den nya har Pro-versionen medan den gamla har Home-utgåvan.

Filterhjulet ska enligt SX inte behöva någon programvara för att kunna kopplas till Windows och testas med SX eget enkla program för att kolla att hjulet snurrar och att filterbytena sker enligt önskemål. Så funkar det också på den gamla minidatorn liksom en ungefär lika gammal laptop som kör Win 7.

Men på den nya laptopen liksom på 2 andra Win 10 Pro maskiner så kommunicerar den inte alls med filtersnurran. I enhetshanteraren kan jag se hur det blinkar med "okänd enhet" och inget händer.
Jag har också provat att ladda in det speciella Ascom drivpaket för snurran som finns på SX hemsida, men det blev ingen kontakt i alla fall.

Är det någon som har en gissning vad det kan vara som krånglar?
Jag vet att Terry Platt på SX brukar vara snabb att svara, men jag tänkte prova här först.

/Lasse
hbar
Inlägg: 421
Blev medlem: 2010-05-14 18:22:47
spamtest: JA
Ort: Lund

Re: Får inte kontakt med SX filtersnurra

Inläggav hbar » 2017-07-08 16:20:41

Prova o ladda in sx driver innan du kopplar in hjulet. Även om de säger att det inte behövs någon speciell driver så har ofta w10 problem att hitta rätt.
https://www.sxccd.com/drivers-downloads

/Håkan
RCX400-12, C8, WO158, WO98
Daystar Quantum 0.5Å, CGE, CGEPro
Användarvisningsbild
stoffe
Inlägg: 1699
Blev medlem: 2011-12-04 00:36:14
spamtest: JA
Ort: Uppsala (UAA)

Re: Får inte kontakt med SX filtersnurra

Inläggav stoffe » 2017-07-08 17:20:14

Om filterhjulet kommunicerar med RS232 så behövs ingen drivrutin. Men till USB behövs det alltid en drivrutin men vissa astroprylar blir antingen en RS232-port i enhetshanteraren eller en HID-device och då finns drivrutiner i regel inbyggt i Windows.
Kameror: Nikon D600, ZWO ASI290MM, QHY9
Newtonteleskop: ZW305 12" f/5, Cave Astrola Deluxe B 1965 8" f/8, TS Optics 8" f/4
Refraktorer: Nikon 300 mm f/2.8 + ytterligare några Nikongluggar
Bygger EQMOD-kablar på beställning.
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 17:38:49

Tack för tipsen men jag hade redan provat med att ha Ascomdrivrutiner installerade innan kameran kopplades in men det hjälpte inte.
Den hamnar som en blinkande USB-enhet i HID-katalogen och när jag högerklickade på den och lät den söka online efter uppdaterad drivrutin så får jag svaret att den senaste redan är installerad.

/Lasse
Magnus Nyborg
Inlägg: 195
Blev medlem: 2012-07-18 19:46:55
spamtest: JA
Ort: Örebro

Re: Får inte kontakt med SX filtersnurra

Inläggav Magnus Nyborg » 2017-07-08 17:44:17

Jag har under mina år råkat ut för några varianter av problem med SX Filterhjul, så jag vet att drivrutinerna kan krångla till det ganska ordentligt.

Har du prövat om du kan använda 'SX Filter wheel control program' vilken använder en mer direkt kontroll av filterhjulet? Finns att ladda ned från http://www.sxccd.com/drivers-downloads en bit ned på sidan.

Om denna fungerar så kan det vara en fråga om felassociationer av windows rörande drivrutinerna, jag kan se om jag hittar instruktionerna för att åtgärda detta om så är fallet.

Jag har inte använt mitt filterhjul sedan i höstas, men då fungerade det på Win10. Om det fortsätter krångla för dig så kan jag kontrollera på min sida.

mvh,
Magnus
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 17:56:40

Hej Magnus,
Jag har provat det men det kräver att jag ska ange USB-port och datorn vill inte upprätta någon anslutning alls.

/Lasse
micke187
Inlägg: 495
Blev medlem: 2015-04-30 14:23:53
spamtest: JA
Ort: Säffle

Re: Får inte kontakt med SX filtersnurra

Inläggav micke187 » 2017-07-08 18:04:42

Har du loggat in som administratör på datorn?
SXvr H-18mono
SW80ED+0.85 ff/fr
Arduinostyrd fokuserare med Nema17 motor
Heq5 pro Rowan mod
Starguider 60mm,Qhy5l-ii
Program:APT ,PHD2
DSS,Nebulosity,PS
Användarvisningsbild
stoffe
Inlägg: 1699
Blev medlem: 2011-12-04 00:36:14
spamtest: JA
Ort: Uppsala (UAA)

Re: Får inte kontakt med SX filtersnurra

Inläggav stoffe » 2017-07-08 18:06:33

Efter @micke187 svar så följ detta vidare.

ASCOM-drivrutin har i regel inte en inbyggd drivrutin för Windows. Det är två olika drivrutiner. Om du inte får den att fungera i enhetshanteraren så kommer du aldrig att lyckats med ASCOM-drivrutinen heller. Första steget är alltså att titta i enhetshanteraren och se om du lyckats få den att fungera där. Det ska inte finnas !?-tecken i enhetshanteraren, det betyder konflikt eller att drivrutiner saknas eller är felaktiga på något sätt. Sedan när filterhjulet är installerat kan du mixtra med ASCOM-drivrutinen och se om du kan få kontakt med det. Annars har inte ASCOM-drivrutinen någon enhet att kommunicera med om inte enheten är installerad.

Om det inte ska behövas någon speciell drivrutin från tillverkaren ladda hem senaste från Windows update. Öppna system i kontrollpanelen, klicka på Advanced system settings, växla till fliken Hardware, klicka på Device Installation Settings, om det står Nej/No där ändra till Ja/Yes (beroende på språkversion av Windows). Sedan kan du koppla ur och in enheten och se om den installerar sig.

Funkade det?
Kameror: Nikon D600, ZWO ASI290MM, QHY9
Newtonteleskop: ZW305 12" f/5, Cave Astrola Deluxe B 1965 8" f/8, TS Optics 8" f/4
Refraktorer: Nikon 300 mm f/2.8 + ytterligare några Nikongluggar
Bygger EQMOD-kablar på beställning.
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 18:24:54

Det kändes klockrent att det skulle vara fel inloggning när jag läste era svar Micke och Stoffe, men när jag kollar i Inställningar/Din information/ så står det Lokalt konto, Administratör pss som i den gamla datorn med Win 10 där det funkar.
Anledningen till att jag inte vill använda den är att det brändes några kretsar i den vid ett åsknedslag i fjol. Emellertid fungerar filterhjulet alldeles utmärkt...

Och jag kollade datorn med Windows Update och den var uppdaterad idag. Jag gick till fliken du nämnde Stoffe men det stod redan Ja där.

Och den fortsätter spela 3-tons strofer som betyder att den inte hittar filterhjulet när jag provar igen :D
Användarvisningsbild
stoffe
Inlägg: 1699
Blev medlem: 2011-12-04 00:36:14
spamtest: JA
Ort: Uppsala (UAA)

Re: Får inte kontakt med SX filtersnurra

Inläggav stoffe » 2017-07-08 18:40:57

Men då är alltså filterhjulet installerat i enhetshanteraren korrekt? Ändå får inte ASCOM-drivrutinen inte kontakt med filterhjulet?

Stämmer det?

Vad blir filterhjulet för enhet i enhetshanteraren? HID, Com-port eller något tredje alternativ?
Kameror: Nikon D600, ZWO ASI290MM, QHY9
Newtonteleskop: ZW305 12" f/5, Cave Astrola Deluxe B 1965 8" f/8, TS Optics 8" f/4
Refraktorer: Nikon 300 mm f/2.8 + ytterligare några Nikongluggar
Bygger EQMOD-kablar på beställning.
micke187
Inlägg: 495
Blev medlem: 2015-04-30 14:23:53
spamtest: JA
Ort: Säffle

Re: Får inte kontakt med SX filtersnurra

Inläggav micke187 » 2017-07-08 19:05:23

Kör du allt genom en usbhubb så det är så enkelt att du glömt strömmen till den? Hänt mig att eqmod och guidekameran inte ville funka men sen när det blev ström till usbhubben funka allt som de skulle.
Har också Windows 10 och hade inga problem alls att installera och starta filterhjulet.
SXvr H-18mono
SW80ED+0.85 ff/fr
Arduinostyrd fokuserare med Nema17 motor
Heq5 pro Rowan mod
Starguider 60mm,Qhy5l-ii
Program:APT ,PHD2
DSS,Nebulosity,PS
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 19:06:20

Nej, hjulet blir aldrig installerat i enhetshanteraren. Jag uttryckte mig lite dåligt där.

Den blinkar till med jämna mellanrum i enhetshanterarens HID-katalog som en USB-enhet med en varningstriangel på sig när Windows försöker ansluta, sen kopplar Win ifrån och så försöker den ansluta igen osv.

Jag högerklickade på den när den blinkade till med sin varningstriangel och fick den att leta drivrutin men den svarade då att den senaste var installerad men det är tydligen ingen som fungerar i vilket fall.

Jag kan ingenting om HID-enheter men jag skrev ner versionen på den som fungerar i gamla datorn och det är samma som visas när jag högerklickade på den blinkande enheten med varningstriangeln.

Sen skrev jag att min nya laptop hade Win Pro men det var fel. Den har Win Home liksom den gamla datorn.
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 19:13:04

Micke,

Jag kör genom den enda USB2-anslutningen på laptopen (USB3 och C annars) och det fungerar med annan utrustning. För att dubbelkolla körde jag just in en Orion Starshoot Autoguider i samma port och den hoppade igång direkt.

Det börjar kännas som att det sitter en slumpgenerator och avgör på vilken dator snurran ska funka :D

/Lasse
micke187
Inlägg: 495
Blev medlem: 2015-04-30 14:23:53
spamtest: JA
Ort: Säffle

Re: Får inte kontakt med SX filtersnurra

Inläggav micke187 » 2017-07-08 19:53:51

Det var precis så du beskrev att det kom en varningstriangel och att den höll på att försöka få kontakt med kamera och eqmodprogrammet till monteringen. Kan ju också vara glappkontakt i usbkabeln eller kontakt.
Annars har du det jobbiga att avinstallera allt och installera allt innan du kopplar i filterhjulet igen å se om de kan funka.
Om det inte är nåt av det så har inte ja mer att komma med i hjälpväg men hoppas de reder ut sig till slut :)
/MIcke
SXvr H-18mono
SW80ED+0.85 ff/fr
Arduinostyrd fokuserare med Nema17 motor
Heq5 pro Rowan mod
Starguider 60mm,Qhy5l-ii
Program:APT ,PHD2
DSS,Nebulosity,PS
Lazze
Inlägg: 970
Blev medlem: 2008-06-04 20:10:08
Ort: Karlskoga

Re: Får inte kontakt med SX filtersnurra

Inläggav Lazze » 2017-07-08 20:19:39

Jag dubbelkollade kabeln för säkerhets skull men den var Ok.

Jag ska ta kontakt med Terry Platt på SX innan jag avinstallerar och kör om allt men jag är väldigt tacksam för alla tips i alla fall även om det inte blev någon lösning den här gången. Det är fantastiskt så mycket hjälp som man ändå kan få en sen lördag på det här forumet :good:

/Lasse

Återgå till "Programvara"

Vilka är online

Användare som besöker denna kategori: 2 och 0 gäster